Linn Forums

Current time: 2017-10-22, 22:00 Hello There, Guest! (LoginRegister)

Linn Forums / Linn Music Systems & Hi-fi Separates / Troubleshooting v / M4A files will not play following the most recent update.

Post Reply 
M4A files will not play following the most recent update.
2016-08-16, 19:03
Post: #1
M4A files will not play following the most recent update.
System sees M4A but will simply not play following the most recent DSM updateOur hard disc storage is a QNAP, the system worked fine until the most recent update.
Find all posts by this user
Quote this message in a reply
2016-08-16, 21:34
Post: #2
RE: M4A files will not play following the most recent update.
Which server software are you using on your NAS? Do other file types play OK?

What is the firmware version to which you updated? Have you tried reverting to the previous version?

David
Find all posts by this user
Quote this message in a reply
2017-09-24, 06:33 (This post was last modified: 2017-09-24 06:37 by prof.)
Post: #3
RE: M4A files will not play following the most recent update.
I'm seeing the same problem.

* Kazoo 4.11.242 (MacOS 10.12.6)
* MinimServer 0.8.0 Update 104

.mp3 files play just fine; .flac files play just fine.
But .m4a files (aac or alac) fail to play, with the error "Failed to add track to DS".

Switching ControlPoint to Lumin.app (iOS), all files play just fine. So the issue is with Kazoo (MacOS)
Find all posts by this user
Quote this message in a reply
2017-09-24, 07:54
Post: #4
RE: M4A files will not play following the most recent update.
(2017-09-24 06:33)prof Wrote:  I'm seeing the same problem.

* Kazoo 4.11.242 (MacOS 10.12.6)
* MinimServer 0.8.0 Update 104

.mp3 files play just fine; .flac files play just fine.
But .m4a files (aac or alac) fail to play, with the error "Failed to add track to DS".

Switching ControlPoint to Lumin.app (iOS), all files play just fine. So the issue is with Kazoo (MacOS)

Not necessarily. It depends on where the file is. Could be Minimserver needs rescanning and the one that works from Lumin is from it's own index rather than Minim's.

Akurate EDSM | Majik ExaktBox-I [on Custom Design iRAPs] | Majik 140, REL T5
Rega RP1, [DS214play +Jitterbug, MinimServer], Kazoo [Linx1010]

AV: Marantz NR1506 | B&W 652(C), M1(S), REL T5 (LFE) | Fronts powered by Linn
Net: NetGear DGN2200 | GS108 | AQ Forest x3

Hello to Jason Isaacs
Visit this user's website Find all posts by this user
Quote this message in a reply
2017-09-24, 08:48
Post: #5
RE: M4A files will not play following the most recent update.
(2017-09-24 07:54)timster Wrote:  Not necessarily. It depends on where the file is. Could be Minimserver needs rescanning and the one that works from Lumin is from it's own index rather than Minim's.

I've rescanned the MinimServer multiple times. That's not the issue.

To be clear, Kazoo can see the file. I can select it to "Play Now". If the file is .mp3 or .flac, it plays just fine. If it's .m4a, it fails to play (with the aforementioned error).

This is quite consistent, across my entire library.
Find all posts by this user
Quote this message in a reply
2017-09-24, 10:05
Post: #6
RE: M4A files will not play following the most recent update.
Odd. I have one m4a album and it works fine (although I have noticed that the Kazoo Track Info incorrectly says its codec is wav - when it plays, the now-playing screen shows it correctly as AAC. That may be the server (Asset in this case - my minim transcodes m4a to wav).
When you say fails to play I'm not sure you mean that - "fail to add" in kazoo means it never got as far as trying to play it - it never got into the DS playing queue. And it is quite unusual. Try transcoding in minim to wav and see if that works. Not sure what that would prove though!

Akurate EDSM | Majik ExaktBox-I [on Custom Design iRAPs] | Majik 140, REL T5
Rega RP1, [DS214play +Jitterbug, MinimServer], Kazoo [Linx1010]

AV: Marantz NR1506 | B&W 652(C), M1(S), REL T5 (LFE) | Fronts powered by Linn
Net: NetGear DGN2200 | GS108 | AQ Forest x3

Hello to Jason Isaacs
Visit this user's website Find all posts by this user
Quote this message in a reply
2017-09-24, 21:06
Post: #7
RE: M4A files will not play following the most recent update.
(2017-09-24 10:05)timster Wrote:  When you say fails to play I'm not sure you mean that - "fail to add" in kazoo means it never got as far as trying to play it - it never got into the DS playing queue.

Sorry to have been unclear. You are correct: it never got added to the DS playing queue.

Quote:Try transcoding in minim to wav and see if that works. Not sure what that would prove though!

I'll have to install MinimStreamer and FFMpeg to do that (which I should get around to, anyway).

But, as you say, it's not clear what that would prove. I have no trouble with other file formats (mp3, flac), so I expect wav should be no problem.
Find all posts by this user
Quote this message in a reply
2017-09-24, 21:51
Post: #8
RE: M4A files will not play following the most recent update.
(2017-09-24 21:06)prof Wrote:  
Quote:Try transcoding in minim to wav and see if that works. Not sure what that would prove though!

I'll have to install MinimStreamer and FFMpeg to do that (which I should get around to, anyway).

But, as you say, it's not clear what that would prove. I have no trouble with other file formats (mp3, flac), so I expect wav should be no problem.

As you predicted, transcoding to wav (in MinimServer) succeeds. All the files play just fine now.

So I supposed this is a valid workaround for Kazoo (apparently) not supporting m4a files (alac or aac). But I still think the latter is a bug that should be fixed ...
Find all posts by this user
Quote this message in a reply
2017-09-24, 22:27
Post: #9
RE: M4A files will not play following the most recent update.
M4A in ALAC format works for me with Kazoo 4.11.242 on MacOS 10.12.6 with MinimServer 0.8.4 Update 104.

Is this perhaps a problem with AAC files?

http://www.last.fm/user/mcgillroy

MDSM/2 - 6100/D - active Kabers - Nubert 441w sub + Qobuz Sublime.
Find all posts by this user
Quote this message in a reply
2017-09-25, 04:10 (This post was last modified: 2017-09-25 04:51 by prof.)
Post: #10
RE: M4A files will not play following the most recent update.
(2017-09-24 22:27)mcgillroy Wrote:  M4A in ALAC format works for me with Kazoo 4.11.242 on MacOS 10.12.6 with MinimServer 0.8.4 Update 104.

Is this perhaps a problem with AAC files?

I first noticed the problem for ALAC files. It seems to apply to both.

The problem vanishes completely, if you turn on transcoding for ALAC and AAC files in MinimStreamer (or switch to another ControlPoint).
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)