Linn Forums

Current time: 2017-12-16, 13:57 Hello There, Guest! (LoginRegister)

Linn Forums / Linn Music Systems & Hi-fi Separates / Troubleshooting v / Strange Konfig Issue

Post Reply 
Strange Konfig Issue
2017-10-04, 14:39
Post: #21
RE: Strange Konfig Issue
could be someone's hacker experienced neighbour grown tired of buffalo soldier got to linn's software ?
Find all posts by this user
Quote this message in a reply
2017-10-04, 15:03
Post: #22
RE: Strange Konfig Issue
Don't want to jump the gun too soon, but mine seems to be working again. Not had any official update as yet.
Find all posts by this user
Quote this message in a reply
2017-10-04, 15:14
Post: #23
RE: Strange Konfig Issue
All,

I have had confirmation from Linn that this issue is now resolved and I am now able to successfully perform Speaker and Space Optimisation updates on both my Sneaky and Renew devices.

No news on the cause yet, but thanks to everyone who contributed.

ffrr
Find all posts by this user
Quote this message in a reply
2017-10-04, 15:44
Post: #24
RE: Strange Konfig Issue
Yes it works on my Mac again.

Not being rude, but it is a shame that someone from Linn did not acknowledge the problem and tell us it is resolved.

Some of us try to provide information to be helpful, and a word to say you are at least listening would be appropriate

Thanks
Donuk sunny downtown York
Visit this user's website Find all posts by this user
Quote this message in a reply
2017-10-04, 16:00
Post: #25
RE: Strange Konfig Issue
As Konfig started to work again here as well, my best bet is, that in my case Konfig needed to call home after downloading the new assets, but for some reason it has failed.

AEDSM > KEB/1 x 2 > Linn Silvers > A4200/1 x 2 > K200 > MISOs
Find all posts by this user
Quote this message in a reply
2017-10-04, 16:05
Post: #26
RE: Strange Konfig Issue
Yes I'm hoping Linn will be along with an update at some point as I'm interested to understand what happened.

I ran tcpview to look at all the external connections that Konfig was making and they were all successful. Usually if something is failing you would see sys_sent instead of established tcp connections. Perhaps a server/app had hung but was still accepting connections.
Find all posts by this user
Quote this message in a reply
2017-10-04, 16:23
Post: #27
RE: Strange Konfig Issue
(2017-10-04 16:05)ffrr Wrote:  Yes I'm hoping Linn will be along with an update at some point as I'm interested to understand what happened.

+1.

AEDSM > KEB/1 x 2 > Linn Silvers > A4200/1 x 2 > K200 > MISOs
Find all posts by this user
Quote this message in a reply
2017-10-05, 14:59
Post: #28
RE: Strange Konfig Issue
Apologies for the lack of forum communication here. I was working directly with our service team on this problem and was completely oblivious otherwise.

Recently a customer purchased/upgraded to a new Katalyst system with a use case we had not yet considered. In an attempt to get this customer up and running with what seemed like a trivial fix, we managed to break the entire Exakt deployment system. A better test is now and place to stop this happening again. Konfig will also be updated to provide better feedback than an endless in progress message.
Find all posts by this user
Quote this message in a reply
2017-10-05, 16:48
Post: #29
RE: Strange Konfig Issue
(2017-10-05 14:59)joshh Wrote:  Apologies for the lack of forum communication here. I was working directly with our service team on this problem and was completely oblivious otherwise.

Recently a customer purchased/upgraded to a new Katalyst system with a use case we had not yet considered. In an attempt to get this customer up and running with what seemed like a trivial fix, we managed to break the entire Exakt deployment system. A better test is now and place to stop this happening again. Konfig will also be updated to provide better feedback than an endless in progress message.


Thanks Josh for giving this update. To me it came as a surprise that running my Exaktbox was direct depending of something happening is Scotland. I agree that it is wise to review the overall system architecture of having this dependency and to strive to loosely coupled system environment. Disturbances @ Linn should not impact the consumer system availability. Hence no impact on unplanned down times. Looking forward to the progress Linn will be making on this matter.

Good luck, Willem
Find all posts by this user
Quote this message in a reply
2017-10-05, 18:51
Post: #30
RE: Strange Konfig Issue
(2017-10-05 16:48)Wballemans Wrote:  
(2017-10-05 14:59)joshh Wrote:  Apologies for the lack of forum communication here. I was working directly with our service team on this problem and was completely oblivious otherwise.

Recently a customer purchased/upgraded to a new Katalyst system with a use case we had not yet considered. In an attempt to get this customer up and running with what seemed like a trivial fix, we managed to break the entire Exakt deployment system. A better test is now and place to stop this happening again. Konfig will also be updated to provide better feedback than an endless in progress message.


Thanks Josh for giving this update. To me it came as a surprise that running my Exaktbox was direct depending of something happening is Scotland. I agree that it is wise to review the overall system architecture of having this dependency and to strive to loosely coupled system environment. Disturbances @ Linn should not impact the consumer system availability. Hence no impact on unplanned down times. Looking forward to the progress Linn will be making on this matter.

Good luck, Willem

I think this prevented Konfig working properly but an already set-up system shouldn't have broken - I was listening to music throughout on my setup. Are you saying that your system was working prior to this incident, stopped and then would no longer play music until Linn fixed the problem?
Perhaps you were using Konfig whilst the change that broke everything was implemented and as such left your Exaktbox in an unusable state?

I don't think it's correct to say that an Exaktbox needs a permanent connection to Linn in order to operate. Easy enough to test, just disconnect your router from the Internet.

ADs/2 -> Klimax Exaktbox/1 -> Silvers -> 2xKCT/D -> K200 -> Ninka
Exaktbox Sub - BK Sub
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)