Linn Forums

Current time: 2018-07-20, 15:25 Hello There, Guest! (LoginRegister)

Linn Forums / Linn Music Systems & Hi-fi Separates / Development v / Linn DS Discovery over WiFi

Post Reply 
Linn DS Discovery over WiFi
2018-03-13, 19:06
Post: #61
RE: Linn DS Discovery over WiFi
Thank you Simon for sharing your thinking, maybe some of the great minds on here can helpSmile

I will test your Beta as I’m a glutton for punishment....


Avalon

Akurate Exakt DSM,2 Akurate Katalyst Exaktbox 6. 2 Akurate 4200 power amps, klimax chakra twin(Dk), Akubarik High Gloss Rosewood speakers,nordost Tyr interconnects, iPad 2 & KazooServer Minimserver and Asset server running on a Qnap 251, backed up to remote Qnap 231. Sonos for multiroom. SPACED OUT
Find all posts by this user
Quote this message in a reply
2018-03-23, 15:47
Post: #62
RE: Linn DS Discovery over WiFi
(2018-03-09 14:54)Simon Chisholm Wrote:  
(2018-03-08 20:13)timster (RadiatorCatHammock) Wrote:  The fact that BubbleUPnP finds all my devices when this happens (including the Akurate DSM as a "UPnP AV" device) shows this is entirely down to OpenHome and/or Linn's implementation of it.

This might be caused by issues on your network, preventing your DS from making connections to your control point(s) to update them on changes in DS state. When this next happens, could you force a crash on your DS then PM me a note of the time this happened and your DS product id please?

If the problem is with your DS being unable to connect to your mobile devices, the only short term resolution would be to improve reliability of your wireless network. We do have plans for additional control protocols with a different approach to eventing but this is a substantial effort and is a medium/long term aim.

PM sent

♫ ♫ Akurate EDSM | AEBox10 [on Custom Design iRAPs] | M6100+2100 | Majik 140 [on alu stands] | REL T5
♫ ♫ Rega RP1, [QNAP HS-251+, Jitterbug, MinimServer, Asset], Kazoo

AV: Marantz NR1506 | B&W 620(C), M1(S), REL T5 (LFE) | Fronts powered by Linn
Net: NetGear DGN2200 | GS108 | AQ Forest x3

Hello to Jason Isaacs
Visit this user's website Find all posts by this user
Quote this message in a reply
2018-03-23, 17:07
Post: #63
RE: Linn DS Discovery over WiFi
(2018-03-23 15:47)timster (RadiatorCatHammock) Wrote:  PM sent

Thanks. We received the crash report but unfortunately it doesn't shed much light on things. The DS log is pretty truncated and only covers one second of use. The snippet we have shows
  • Your DS has been running for just under 2 weeks
  • It was brought out of standby
  • It selected Playlist source and started loading the last track you'd been playing. (This was from Tidal)
  • The DS connected to Tidal correctly and had buffered as much content as possible. It was sitting idle waiting to be told to play (or change track, etc.)
  • One second after coming out of standby, a press-hold of standby began
  • Tens seconds after this, the DS crashed and rebooted

I'd hoped the log would show some failed attempts by the DS to inform a control point of state changes. There was none of this (albeit that the log doesn't cover much DS use). Do you remember how long you'd been attempting to discover your DS for before this time? Also, do you know what had brought the DS out of standby? Could this have been Bubble (implying that it had discovered your DS after all)? Or is it possible that your finger slipped on the remote (meaning that the full log is showing an in-progress press-hold of Standby)?

Looking at your original report again, I see that you mentioned using two control points - Bubble on Android and Kazoo on Windows. If there are any cases where Bubble cannot discover your DS but Kazoo can, a Report to Linn from Kazoo would include far more DS logging than a crash report. If this is possible, could you try that next time please?

Thanks for your patience with this. We do want to get this fixed; getting enough information to either diagnose or reproduce the problem is proving tricky though!
Find all posts by this user
Quote this message in a reply
2018-03-23, 18:03
Post: #64
RE: Linn DS Discovery over WiFi
(2018-03-23 17:07)Simon Chisholm Wrote:  
(2018-03-23 15:47)timster (RadiatorCatHammock) Wrote:  PM sent

Thanks. We received the crash report but unfortunately it doesn't shed much light on things. The DS log is pretty truncated and only covers one second of use. The snippet we have shows
  • Your DS has been running for just under 2 weeks
  • It was brought out of standby
  • It selected Playlist source and started loading the last track you'd been playing. (This was from Tidal)
  • The DS connected to Tidal correctly and had buffered as much content as possible. It was sitting idle waiting to be told to play (or change track, etc.)
  • One second after coming out of standby, a press-hold of standby began
  • Tens seconds after this, the DS crashed and rebooted

I'd hoped the log would show some failed attempts by the DS to inform a control point of state changes. There was none of this (albeit that the log doesn't cover much DS use). Do you remember how long you'd been attempting to discover your DS for before this time? Also, do you know what had brought the DS out of standby? Could this have been Bubble (implying that it had discovered your DS after all)? Or is it possible that your finger slipped on the remote (meaning that the full log is showing an in-progress press-hold of Standby)?

Looking at your original report again, I see that you mentioned using two control points - Bubble on Android and Kazoo on Windows. If there are any cases where Bubble cannot discover your DS but Kazoo can, a Report to Linn from Kazoo would include far more DS logging than a crash report. If this is possible, could you try that next time please?

Thanks for your patience with this. We do want to get this fixed; getting enough information to either diagnose or reproduce the problem is proving tricky though!

Gosh. I'll try and answer!

I am pretty sure when forcing the crash I kept my finger on the remote power button until the flashing dot - but I suppose it could be that it got interrupted or something - so from the DS end it could have looked like a single press followed by along-press immediately after? So it went into standby before the crash? If a 10 second-press of the power button when in standby will also force a crash, that would explain the log. Darn.
OK - note to self - use the front power button next time! It seems anything you were hoping for has been lost this time.

I have never had a case where Bubble can't find the DS while Kazoo can. If anything it's the other way round. But I will try and look out for that next time too.

This is the sequence of events up to the standby/forced crash anyway, if it helps:

I was playing an album from Tidal, that much is true. I always keep the DS in standby - 2 weeks sounds about right!
I was using Kazoo on my Windows10 tablet. I power-on the DS with this (which was a long time before this happened - I had been playing quite a few things beforehand). If it helps, startup source is Playlist, Autoplay is Off.
The immediate time before the discovery failure however:
I selected the album from Tidal, selected Play Now. All perfectly normal and played.
I came out of kazoo to do something else, then it was when I restarted kazoo again that it was in "waiting" mode. The DS had been playing the album for a while by then, possibly half-way through the album.
When this happened I went into kazoo settings, which sometimes prompts it to find the DS. But it didn't. So I closed Kazoo and restarted it. Same thing - waiting, went in to settings, still waiting.
At this point I thought it would be prudent to do the forced crash - I used the remote to do this (long press on the power button) - but I did pause the playback first (possibly erroneously). If that wasn't in the log, it does seem it was a double-press of the standby button.

Oh well. Until next time...

♫ ♫ Akurate EDSM | AEBox10 [on Custom Design iRAPs] | M6100+2100 | Majik 140 [on alu stands] | REL T5
♫ ♫ Rega RP1, [QNAP HS-251+, Jitterbug, MinimServer, Asset], Kazoo

AV: Marantz NR1506 | B&W 620(C), M1(S), REL T5 (LFE) | Fronts powered by Linn
Net: NetGear DGN2200 | GS108 | AQ Forest x3

Hello to Jason Isaacs
Visit this user's website Find all posts by this user
Quote this message in a reply
2018-06-10, 07:23
Post: #65
RE: Linn DS Discovery over WiFi
PM sent - but it may be a different issue?

♫ ♫ Akurate EDSM | AEBox10 [on Custom Design iRAPs] | M6100+2100 | Majik 140 [on alu stands] | REL T5
♫ ♫ Rega RP1, [QNAP HS-251+, Jitterbug, MinimServer, Asset], Kazoo

AV: Marantz NR1506 | B&W 620(C), M1(S), REL T5 (LFE) | Fronts powered by Linn
Net: NetGear DGN2200 | GS108 | AQ Forest x3

Hello to Jason Isaacs
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)